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1. Document Formatting 

Automated templates demand superior formatting to ensure that the text behaves as required when 

customised adjustments are applied during the document generation process. 

While a template may appear to be well crafted, it’s imperative to ensure that this remains the case with 

every generated iteration. 

A generated document needs to be flexible for post docgen alterations and should help the drafter by making 

this as simple as possible. Builders need to apply formatting that will control how the document responds to 

further manual changes. 

2. Best Practices 

This guide provides tips and identifies key formatting tools that can assist in controlling the behaviour of text 

during both the docgen and post docgen phases. It is recommended that builders familiarise themselves with 

these tools and apply them as their usual formatting best practices. 
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2.1 Developer Tab and Design Mode 

In Word, the Developer Tab is turned off by default and needs to be enabled for access to automation tools. 

1. On the Word Ribbon, go to the File tab. 

2. Click Options. 

3. Click Customise ribbon. 

4. In Choose commands from column – select Popular Commands. 

5. In the Customise the Ribbon column – select Main Tabs. 

6. Tick the Developer checkbox. 

7. Click OK. 

  

Microsoft help article 
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When the Developer Tab appears on the Ribbon, click on it and click Design Mode. 

 

2.2 Show Paragraph Formatting 

In Word, paragraph formatting is turned off by default. For an accurate view of what is happening with the 

formatting of your document, always reveal paragraph formatting. 

1. On the Word Ribbon, go to the Home tab. 

2. Go to the Paragraph group. 

3. Click the Show/Hide button. 

 

Microsoft help article 

Note: When working on templates ALWAYS: 
 have the Developer Tab enabled 
 have Design Mode turned on 
 reveal Paragraph Formatting 

2.3 Quick Access Toolbar 

Set up your Quick Access Toolbar to include the most common document automation tools. 

1. On the Word Ribbon, go to the File tab. 

2. Click Options. 

3. Click Quick Access Toolbar. 

4. In Choose commands from column – select All Commands. 

5. Select the relevant tools and click Add. 

6. Use the up and down arrows to reorder your selections. 

7. Click OK. 
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Examples of common features to include in the Quick Access Toolbar are: 

 

The selected options will appear on the Word Ribbon, eg: 

 

Microsoft help article 
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2.4 Normal.dot and Styles 

Ensure all automated documents are built using the organisation’s Normal.dot and custom styles. 

The Normal.dot template opens whenever you start Microsoft Word and it includes the default styles and 

customisations for your organisation’s preferences and settings. 

Your organisation should have (and if not, they should create) a custom Normal.dot in preparation for 

automation. This will ensure the consistency and integrity of both the automated and generated versions of 

documents. 

The same Normal.dot is used by everyone in the organisation and is usually set to reload on each login from 

the main source and is stored for each individual user at: 

C:\Users\user name\AppData\Roaming\Microsoft\Templates 

The organisation’s Normal.dot should have a single instance and a user should never alter their own version. 

The person managing the Normal.dot should ensure it complies with the organisation’s preferences and 

settings for: 

 Font type and point size 

 Paragraph spacing and alignment 

 Page size and margins 

 Preferred settings enabled/disabled as required 

 Custom styles have been created 

 Custom number and bullet lists have been created 

Normal.doc: Microsoft help article 

Custom styles: Microsoft help article 

Custom lists: Microsoft help article 

Note: If custom styles and lists haven’t been created, this should be done before commencing automation. 

2.5 Avoid Using Empty Returns for Spacing 

Use paragraph settings to create the spacing required rather than inserting empty carriage returns. 

1. On the Word Ribbon, go to the Layout tab. 

2. Go to the Paragraph group. 

3. Adjust the Before/After settings. 
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The settings to apply will depend on the size of font you’re using and how much of a gap you need. 

EG: For 12 point font, 6pt is half a line and 12pt is a full line. 

  

Microsoft help article 

2.6 Avoid Unnecessary Blank Pages at the End of a Document 

Ensure you delete all empty returns at the end of a document to avoid unnecessary blank pages forming. Use 

the paragraph before/after settings per 2.5 above to adjust spacing. 

Microsoft help article 

2.7 Soft Returns vs Hard Returns 

Soft return: Shift+Enter 

Hard return: Enter 

Hard returns should be used wherever possible. 

Soft returns should only be used where formatting has been applied and the formatting will only continue if a 

soft return is used. If a new number/bullet is not required, then a soft return will continue all other formatting 

without applying a new number/bullet (eg indents). 

Soft returns should be avoided where possible. Using soft returns unnecessarily will adversely impact other 

formatting, especially keep-with-next settings. 

2.8 Ensure Headings and Introductory Paragraphs Stay 

Connected to the First Subpara Below it 

Depending on the answers provided by the filler and the corresponding text that is inserted into the generated 

document, headings and intro paragraphs in the template will move and may become disconnected to the 

text below it.  To avoid a heading or intro paragraph from sitting at the bottom of the page while the text 

splits onto the next page, apply keep with next and Widow/Orphan controls to the heading or intro paragraph 

to ensure they move together. 



 

8 

Apply keep with next and Widow/Orphan control to all headings, subheadings and any paragraph that is 

introducing something (this would usually be a paragraph that ends with a colon). 

When these settings are applied, a non-printing square character will appear in the margin to indicate a 

paragraph control has been applied: 

 

1. On the Word Ribbon, go to the Layout tab. 

2. Go to the Paragraph group. 

3. Click the arrow to expand the group options. 

4. Click the Line and Page Breaks tab. 

5. Tick Widow/Orphan control. 

6. Tick Keep with next. 

7. Click OK. 

 

Microsoft help article 
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2.9 Avoid Manual Page Breaks 

Page breaks can take up room in your document that can unknowingly create an extra page.  Also, it can 

sometimes make formatting the next paragraph difficult as it likes to carry the formatting from the 

paragraph above. Instead, use the Page Break Before setting. 

1. On the Word Ribbon, go to the Layout tab. 

2. Go to the Paragraph group. 

3. Click the arrow to expand the group options. 

4. Click the Line and Page Breaks tab. 

5. Tick Page Break Before. 

6. Click OK. 

 

Microsoft help article 
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2.10 Control the Size of Table Rows and Columns 

Word has a default setting enabled that will automatically resize table columns and rows to suggest the best 

fit for your text. With automation, the amount of text the filler will enter is unknown so to ensure the integrity 

and aesthetics of the table, it is best to lock these settings so that you are in control of the table layout. 

1. Highlight the whole table. 

2. Right-click anywhere in the table. 

3. Select Table Properties. 

4. Click Options. 

5. Untick Automatically resize to fit contents. 

6. Click OK. 

 
Microsoft help article 
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2.11 Control Table Rows Breaking Across the Page 

Word has a default setting enabled that will automatically allow table rows to break across the page. This will 

often make a mess of the table or make it difficult to review later. With automation, the amount of text the 

filler will enter and where a row will break is unknown so to ensure the integrity and aesthetics of the table, it is 

best to lock these settings so that you are in control of the table layout. 

1. Highlight the whole table. 

2. Right-click anywhere in the table. 

3. Select Table Properties. 

4. Click the Row tab. 

5. Untick Allow row to break across pages. 

6. Click OK. 

 
Microsoft help article 

2.12 Set Table Row Height 

When a table is inserted, Word applies the most flexible default settings. With automation, more control is 

required to specify how the table is to behave, in particular the height of rows where you may want – or 

specifically not want - the height of the row to automatically resize. To adjust the settings for table rows: 

1. Highlight the whole table. 

2. Right-click anywhere in the table. 

3. Select Table Properties. 

4. Click the Row tab. 

If the row is to be a specific height, tick the box, set to Exactly and insert the height measurement. 

If the column is to be a specific width, click the Column tab, tick the box and insert the width measurement. 
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If a row needs flexibility to expand, EG the length of an answer may be brief or lengthy, set the row height to 

At Least so that the row can appear small and not unnecessarily expand until additional text is entered and 

extra space is required. 

 

Microsoft help article 

2.13 Ensure Borderless Tables Align Cell Text with General Text 

Outside of the Table 

Table cells have margins applied to pull text away from the borders. This is required when borders are turned 

on and you need some space in-between. When cell borders are turned off, text will appear slightly indented 

within the table and so the cell margins will need to be adjusted so that the text within the table aligns 

properly with the text outside of the table. 

1. Highlight the whole table. 

2. Right-click anywhere in the table. 

3. Select Table Properties. 

4. Click the Cell tab. 

5. Click Options. 

6. Untick Same as the whole table. 

7. Set all margins to zero. 

8. Click OK. 
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The example on the left is before the margins have been adjusted, showing the text misaligned and the line 

spacing differences. 

The example on the right shows the clean adjusted layout. 

 

Note: These settings can also be changed by highlighting the table and making the adjustments on the ruler. 

Microsoft help article 

2.14 Keep Characters Together – Avoid Hyphenated Words and 

Important Words Separating Over Lines 

Use non-breaking hyphens and non-breaking spaces to prevent text breaking. 

Non-breaking hyphen: ALT+SHIFT+Hyphen 

Non-breaking space: CTRL+SHIFT+Space 

Use non-breaking spaces to control text moving together, EG for dates and intro words. 

Microsoft help article 

2.15 Avoid Using Multiple Tab Characters – Set Tabs on the 

Ruler and Use Hanging Indents to Control Text Alignment 

Use Tabs and set indents to control how text will behave across multiple lines. 

You can set tabs and hanging indents directly on the ruler: 

 

To turn the ruler on, go to the View tab. In the Show group, tick the Ruler. 
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The adjustments can also be made in paragraph and tab settings: 

   

Ruler: Microsoft help article 

Indents: Microsoft help article 

2.16 Avoid Inserting Manual Cross-References 

Insert cross-references as fields to ensure they update as adjustments are made to a document and 

paragraph numbering changes. This is imperative in automated documents where paragraphs will be 

included/excluded per the filler’s answers, which will impact numbering and cross-references. 

1. Place the cursor where the cross-reference is to be inserted. 

2. On the Word Ribbon, go to the Insert tab. 

3. Go to the Links group. 

4. Click Cross-reference. 

5. Apply the reference type and insert the reference to option. 

6. Select the paragraph to reference. 

7. Click Insert. 

 

Microsoft help article 
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2.17 Using Bookmarks 

Bookmarks are placeholders and/or reference points, and can be used in Word commands and equations 

(sums). 

1. Place the cursor where the bookmark is to be inserted. 

2. On the Word Ribbon, go to the Insert tab. 

3. Go to the Links group. 

4. Click Bookmark. 

5. Enter a bookmark name in Camel_Case. 

6. Click Add. 

 

Microsoft help article 

2.18 Hard Code to Restart Paragraph Numbering 

Word may not follow numbering continue/restart instructions where multiple numbering lists are used in the 

document. To ensure Word complies with restarts, you may need to hardcode this with a field. 

1. Place your cursor above the numbered list to be restarted. 

2. Insert a Word field by pressing CTRL+F9. 

3. Insert field code:  { LISTNUM \l 1 \s 1 }. 

 

Note: You may need to toggle field codes on/off to see the code – press ALT+F9 
 Ensure the code is entered exactly as above, including spaces 
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Word may assign the line where the code was inserted as “1” so you may need to set the restart to 0. If this 

happens, alter the field code to:  { LISTNUM \l 1 \s 0 }. 

 

If you need to hide the code, set it to hidden text, size 1, white font and adjust the spacing so it can’t be seen 

when generated and to reduce the chances of it being deleted. 

Microsoft help article 

2.19 Code to Count Number of Pages 

You may need to count the pages of a whole document OR the number of pages only within a section. 

Word’s automatic page numbering will default to count all pages of the document and the field code will 

appear as:  { NUMPAGES  \* MERGEFORMAT }. 

 

To set the code to count pages in a section, alter the field code to:  { SECTIONPAGES  \* MERGEFORMAT }. 

 

Note: You may need to toggle field codes on/off to see the code – press ALT+F9 
 Ensure the code is entered exactly as above, including spaces 

Microsoft help article 

 


